Quantcast

Error Message

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Error Message

samannsml (Bugzilla)
Hello Mates,

at the Moment my Build in the OpenSUSE Buildservice fails (OpenSUSE-
Factory). The Packages for 11.0 and 11.1 are successed.
The break are:
>/usr/include/wx-2.8/wx/window.h:1424: error: 'const wxEventTable
>wxWindowBase::sm_eventTable' is protected
>common/wxFlatNotebook.cpp:610: error: within this context
It shows, that the BOINC Source has Problems with an newer WxWidgets.
I've attached the wxFlatNotebook.cpp

Has anyone intuition to fix this?
--
Sincereley yours

Sascha Manns
openSUSE Marketing Team
openSUSE Build Service
openSUSE Features Screening Team
Web: http://saschamanns.gulli.to
Project-Blog: http://lizards.opensuse.org/author/saigkill
Private-Blog: http://saschasbacktrace.blogspot.com


_______________________________________________
wx-dev mailing list
[hidden email]
http://lists.wxwidgets.org/mailman/listinfo/wx-dev

wxFlatNotebook.cpp (60K) Download Attachment
wxFlatNotebook.h (26K) Download Attachment
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Error Message

Julian Smart
Hi,

Sascha 'saigkill' Manns wrote:

> Hello Mates,
>
> at the Moment my Build in the OpenSUSE Buildservice fails (OpenSUSE-
> Factory). The Packages for 11.0 and 11.1 are successed.
> The break are:
>  
>> /usr/include/wx-2.8/wx/window.h:1424: error: 'const wxEventTable
>> wxWindowBase::sm_eventTable' is protected
>> common/wxFlatNotebook.cpp:610: error: within this context
>>    
> It shows, that the BOINC Source has Problems with an newer WxWidgets.
> I've attached the wxFlatNotebook.cpp
>
> Has anyone intuition to fix this?
>  
wxPageContainerBase derives from wxPanel, so this line (610) is wrong:

BEGIN_EVENT_TABLE(wxPageContainerBase, wxControl)

Changing wxControl to wxPanel should do the trick.

Regards,

Julian

--
Julian Smart, Anthemion Software Ltd.
28/5 Gillespie Crescent, Edinburgh, Midlothian, EH10 4HU
www.anthemion.co.uk | +44 (0)131 229 5306
Tools for writers: www.writerscafe.co.uk
wxWidgets RAD:     www.dialogblocks.com
Blog:              www.juliansmart.com

_______________________________________________
wx-dev mailing list
[hidden email]
http://lists.wxwidgets.org/mailman/listinfo/wx-dev
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Error Message (SOLVED)

samannsml (Bugzilla)
Am Freitag 22 Mai 2009 09:37:54 wrote Julian Smart:

> Hi,
>
> Sascha 'saigkill' Manns wrote:
> > Hello Mates,
> >
> > at the Moment my Build in the OpenSUSE Buildservice fails
> > (OpenSUSE- Factory). The Packages for 11.0 and 11.1 are successed.
> >
> > The break are:
> >> /usr/include/wx-2.8/wx/window.h:1424: error: 'const wxEventTable
> >> wxWindowBase::sm_eventTable' is protected
> >> common/wxFlatNotebook.cpp:610: error: within this context
> >
> > It shows, that the BOINC Source has Problems with an newer
> > WxWidgets. I've attached the wxFlatNotebook.cpp
> >
> > Has anyone intuition to fix this?
>
> wxPageContainerBase derives from wxPanel, so this line (610) is
> wrong:
>
> BEGIN_EVENT_TABLE(wxPageContainerBase, wxControl)
>
> Changing wxControl to wxPanel should do the trick.
Thanks for the hint. That was it :-))

--
Sincereley yours

Sascha Manns
openSUSE Marketing Team
openSUSE Build Service
openSUSE Features Screening Team
Web: http://saschamanns.gulli.to
Project-Blog: http://lizards.opensuse.org/author/saigkill
Private-Blog: http://saschasbacktrace.blogspot.com

_______________________________________________
wx-dev mailing list
[hidden email]
http://lists.wxwidgets.org/mailman/listinfo/wx-dev

signature.asc (204 bytes) Download Attachment
Loading...