Quantcast

Problem: wxEVT_TEXT_ENTER with AutoComplete enabled

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Problem: wxEVT_TEXT_ENTER with AutoComplete enabled

Aliket
Hi,

I am a wx user, and i have a problem with wxTextCtrl not generating wxEVT_TEXT_ENTER event when it have autocomplete enabled !

I am not sure if this is a known bug, but if so, i would like to know if there is a workaround for this problem please...

My platform is win7 using the latest wx dev

--
Please read http://www.wxwidgets.org/support/mlhowto.htm before posting.

To unsubscribe, send email to [hidden email]
or visit http://groups.google.com/group/wx-users
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Problem: wxEVT_TEXT_ENTER with AutoComplete enabled

oneeyeman
Hi,

On Sat, Apr 8, 2017 at 8:52 AM, Aliket <[hidden email]> wrote:
> Hi,
>
> I am a wx user, and i have a problem with wxTextCtrl not generating wxEVT_TEXT_ENTER event when it have autocomplete enabled !
>
> I am not sure if this is a known bug, but if so, i would like to know if there is a workaround for this problem please...

It is a known bug and unfortunately there is no (known) workaround.
Just try to search trac.wxwidgets.org for the ticket.

Thank you.

>
> My platform is win7 using the latest wx dev
>
> --
> Please read http://www.wxwidgets.org/support/mlhowto.htm before posting.
>
> To unsubscribe, send email to [hidden email]
> or visit http://groups.google.com/group/wx-users

--
Please read http://www.wxwidgets.org/support/mlhowto.htm before posting.

To unsubscribe, send email to [hidden email]
or visit http://groups.google.com/group/wx-users
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Problem: wxEVT_TEXT_ENTER with AutoComplete enabled

Eric Jensen-10
Hello Igor,

Saturday, April 8, 2017, 3:11:43 PM, you wrote:

IK> Hi,

IK> On Sat, Apr 8, 2017 at 8:52 AM, Aliket <[hidden email]> wrote:
>> Hi,
>>
>> I am a wx user, and i have a problem with wxTextCtrl not generating wxEVT_TEXT_ENTER event when it have autocomplete enabled !
>>
>> I am not sure if this is a known bug, but if so, i would like to know if there is a workaround for this problem please...

IK> It is a known bug and unfortunately there is no (known) workaround.
IK> Just try to search trac.wxwidgets.org for the ticket.

Ticket: http://trac.wxwidgets.org/ticket/12613

From one of the comment (mine actually):
IK> However, the control still does receives the KEY_DOWN event for
IK> the return key, so on the user side an easy workaround is to catch
IK> it and perform the same action as when receiving a EVT_COMMAND_TEXT_ENTER event.

Hth,
Eric


--
Please read http://www.wxwidgets.org/support/mlhowto.htm before posting.

To unsubscribe, send email to [hidden email]
or visit http://groups.google.com/group/wx-users
Loading...