wxWidgets 3.0.2, OS X v10.12.3 (16D32) and xCode v8.2.1 (8C1002) or Code::Blocks 13.12

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

wxWidgets 3.0.2, OS X v10.12.3 (16D32) and xCode v8.2.1 (8C1002) or Code::Blocks 13.12

Enrique Lazcorreta Puigmartí
Hi.

I want to use wxWidgets 3.0.2 over OS X v10.12.3 to get Visual Applications.

  1. Using xCode v8.2.1, when creating the library as explained in https://wiki.wxwidgets.org/Creating_Xcode_projects_for_wxWidgets_applications I get

      /Users/enriquelazcorretapuigmarti/Library/wxWidgets-3.0.2/src/osx/core/bitmap.cpp:39:10: 'QuickTime/QuickTime.h' file not found

      And my search of QuickTime.h with Spotlight give me no results. Where can I find this header?

  2. Also, I would like to use Code::Blocks (16.01 has advantages over 13.12 but I can get only 13.12 version compiled and can't build the last one). Is there a clear way to get it running? I can't get info about this issue.

Thanks in advance,

Enrique

--
Please read http://www.wxwidgets.org/support/mlhowto.htm before posting.
 
To unsubscribe, send email to [hidden email]
or visit http://groups.google.com/group/wx-users
Reply | Threaded
Open this post in threaded view
|

Re: wxWidgets 3.0.2, OS X v10.12.3 (16D32) and xCode v8.2.1 (8C1002) or Code::Blocks 13.12

oneeyeman
Hi,
This is a known issue.
Please try with Hit HEAD or the WX3.0.2 branch (head of the branch).

Thank you.


On Feb 23, 2017 10:21 PM, "Enrique Lazcorreta Puigmartí" <[hidden email]> wrote:
Hi.

I want to use wxWidgets 3.0.2 over OS X v10.12.3 to get Visual Applications.

  1. Using xCode v8.2.1, when creating the library as explained in https://wiki.wxwidgets.org/Creating_Xcode_projects_for_wxWidgets_applications I get

      /Users/enriquelazcorretapuigmarti/Library/wxWidgets-3.0.2/src/osx/core/bitmap.cpp:39:10: 'QuickTime/QuickTime.h' file not found

      And my search of QuickTime.h with Spotlight give me no results. Where can I find this header?

  2. Also, I would like to use Code::Blocks (16.01 has advantages over 13.12 but I can get only 13.12 version compiled and can't build the last one). Is there a clear way to get it running? I can't get info about this issue.

Thanks in advance,

Enrique

--
Please read http://www.wxwidgets.org/support/mlhowto.htm before posting.
 
To unsubscribe, send email to [hidden email]
or visit http://groups.google.com/group/wx-users

--
Please read http://www.wxwidgets.org/support/mlhowto.htm before posting.
 
To unsubscribe, send email to [hidden email]
or visit http://groups.google.com/group/wx-users
Reply | Threaded
Open this post in threaded view
|

Re: wxWidgets 3.0.2, OS X v10.12.3 (16D32) and xCode v8.2.1 (8C1002) or Code::Blocks 13.12

Enrique Lazcorreta Puigmartí
Thanks, Igor.

I don't understand your reply.

"Please try with Hit HEAD or the WX3.0.2 branch (head of the branch)."

There is not HEAD file in wxWidgets directory. Did you mean 'git'? There's no .git.

Can you explain with more details? I'm totally newbie with those tasks.

Thanks

--
Please read http://www.wxwidgets.org/support/mlhowto.htm before posting.
 
To unsubscribe, send email to [hidden email]
or visit http://groups.google.com/group/wx-users
Reply | Threaded
Open this post in threaded view
|

Re: wxWidgets 3.0.2, OS X v10.12.3 (16D32) and xCode v8.2.1 (8C1002) or Code::Blocks 13.12

oneeyeman
Hi.
Yes sorry - I did mean git.
You need to install a git client and become familiar with it.
Then grab latest sources from the repository.

Google is your friend here.

Thank you.


On Feb 24, 2017 12:17 AM, "Enrique Lazcorreta Puigmartí" <[hidden email]> wrote:
Thanks, Igor.

I don't understand your reply.

"Please try with Hit HEAD or the WX3.0.2 branch (head of the branch)."

There is not HEAD file in wxWidgets directory. Did you mean 'git'? There's no .git.

Can you explain with more details? I'm totally newbie with those tasks.

Thanks

--
Please read http://www.wxwidgets.org/support/mlhowto.htm before posting.
 
To unsubscribe, send email to [hidden email]
or visit http://groups.google.com/group/wx-users

--
Please read http://www.wxwidgets.org/support/mlhowto.htm before posting.
 
To unsubscribe, send email to [hidden email]
or visit http://groups.google.com/group/wx-users